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1. Introducción 

Sonic Visualiser es un ​software distribuido bajo licencia libre que nos permite analizar             

diferentes parámetros de una onda sonora. Se trata de una herramienta de gran utilidad              

para el análisis de la música grabada que ha sido desarrollado por el Centre for Digital                

Music de la Universidad Queen Mary de Londres. El programa trabaja solamente a partir de               

archivos de audio, permitiendo visualizar y extraer diferentes parámetros de las           

grabaciones. Sonic Visualiser no es un editor de audio y, por lo tanto, no permite cortar,                

pegar o realizar otras labores de edición sobre el archivo.  

Este ​software aporta un conjunto de herramientas de gran utilidad para aquellos            

musicólogos que se enfrentan al análisis de la ​performance a través de la grabación sonora.               

Gracias a las gráficas de ​tempo​, duración, dinámica, espectrogramas o gráficas           

frecuenciales, es posible extraer datos precisos de los diversos parámetros que componen            

una grabación de una interpretación musical. Además, la superposición de paneles en Sonic             

Visualiser permite la rápida comparación de versiones. Finalmente, el volcado de los datos             

obtenidos en otras aplicaciones informáticas desarrolladas en estrecha vinculación con este           

software​ hace posible una mayor profundización en el análisis. 

 

2. Estructura del menú 

2.1. File 

Como en cualquier otro programa, en el menú File tenemos todas las opciones para crear               

una nueva sesión (New Session), abrir una sesión reciente (Open, Open Location u Open              

Recent) o guardar la sesión que tengamos abierta (Save Session o Save Session As). 

Para abrir un archivo de audio en Sonic Visualiser debemos ir a File > Open o                

arrastrar directamente el archivo de audio desde la carpeta correspondiente hasta la            

ventana principal del programa. 

2.2. View 

Sonic Visualiser presenta diferentes opciones de visualización y navegación por el archivo            

de audio: 
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● View>Scroll Left y View>Scroll Right: ​Nos permite navegar a izquierda y derecha            

(eje temporal) por el archivo de audio. También podemos emplear las flechas ← →              

del teclado del ordenador. Si empleamos las mismas flechas pulsando Ctrl podemos            

navegar por el archivo de audio mediante saltos temporales mayores (Jump Left y             

Jump Right). También podemos desplazarnos por el archivo de audio arrastrando el            

cursor sobre el eje temporal que aparece debajo de la forma de onda. 
● View>Zoom In y View>Zoom Out: ​Nos permite aumentar o disminuir el zoom de la              

onda para una mejor apreciación de los ciclos de compresión y rarefacción u otros              

parámetros como la envolvente. También podemos emplear las flechas ↑ ↓ del            

teclado del ordenador o la rueda central del ratón. 
● View>Show Property Boxes: ​Nos permite visualizar la ventana que aparece a la            

derecha de la pantalla donde podemos monitorizar todos los ​layers activos sobre el             

archivo sonoro. Cada una de las pestañas de esta ventana representa una capa con              

una herramienta de análisis determinada (forma de onda, espectrograma, etc.). 

2.3. Pane 

El menú Pane nos permite añadir ventanas a la ventana de la forma de onda que se abre                  

por defecto al importar un archivo de audio. ​Estos paneles pueden contener otras formas de               

onda y diversos modelos de espectrogramas. Asimismo, podemos añadir un analizador de            

espectro o frecuencial sobre la misma ventana. 
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Imagen 1: Superposición de paneles dentro de un proyecto ( ​waveform ​, ​spectrogram​ y ​spectrum​). 

 

3.3. Layer 

El menú Layer nos permite añadir diferentes capas que se superponen a la capa original               

representada por la forma de onda. Esto facilita, por ejemplo, realizar una comparativa             

sobre la misma ventana del espectrograma de una grabación y de su forma de onda. Cada                

nueva capa creada aparecerá como una nueva pestaña en la ventana “Property boxes” de              

la derecha, donde podemos modificar diferentes opciones de visualización, magnitudes,          

ocultar esa capa, etc.  

Sonic Visualiser ofrece diversas posibilidades de visualización de las formas de onda:  
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● Por canales separados (Channels: Separate): en un archivo estéreo, una          

onda representará el canal izquierdo (​left​) y la otra el canal derecho (​right​). 

 
Imagen 2: Forma de onda correspondiente a dos canales de audio.  

 
● Como una onda no simétrica (Channels: Butterfly). Para una onda estéreo se            

mostrará un solo canal con los picos positivos correspondientes al canal izquierdo            

(​left​) y los picos negativos correspondientes al canal derecho (​right​). 

 
Imagen 3: Forma de onda correspondiente a la vista ​butterfly ​. 
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● Con la forma de onda en forma de canal medio (Channels: Mean): para una              

señal estéreo, un solo canal “promedio” de los dos canales ​left ​y ​right​. Esta              

es la visualización más frecuente, ya que, a lo largo del proceso de análisis,              

la información gráfica que se obtiene es tan compleja que se intenta            

simplificar en la visualización de la forma de onda.  

 
Imagen 4: Forma de onda correspondiente a la vista ​mean ​. 

 

3.4. Transform 

Dentro del menú Transform es posible visualizar todos los ​plugins que tenemos instalados             

en Sonic Visualiser. Este programa emplea una arquitectura de ​plugins llamada Vamp            

Plugins y cuenta con un importante número de desarrolladores que incluyen diferentes            

Universidades y centros de investigación. Estos complementos amplían considerablemente         

la funcionalidad del ​software y pueden ser descargados de la siguiente web:            

https://www.vamp-plugins.org/download.html 

 
 

4. Instalación de los Vamp Plugins 

 
Los Vamp Plugins tienen la extensión .dll en el caso de Windows y .dylib en el caso de                  

OSX. La ruta para la instalación de los Vamp Plugins en Windows es: C:\Program              

Files\Vamp Plugins  
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La ruta para la instalación de los Vamp Plugins en Mac OSX es:             

/Library/Audio/Plug-Ins/Vamp 

 

El último apartado de este tutorial contiene una explicación detallada de diferentes ​plugins             

que forman parte del menú Transform: Mazurka Plugins, ​Vamp Aubio Plugins y BBC Vamp              

Plugins. 

 

5. Playback 

 
En el menú Playback se encuentran todas las opciones de transporte (Play, Pause, Fast              

Forward, Rewind), modificación de la velocidad de reproducción (Speed Up, Slow Down o             

Restore Normal Speed). También permite realizar un ​loop sobre todo el archivo de audio o               

sobre una selección (Loop Playback).  

 

6. Primeros pasos con Sonic Visualiser 

Para explicar las funciones básicas de Sonic Visualiser emplearemos el archivo de audio             

disponible en este ​enlace​. Se trata del primer movimiento, Allegro non troppo, de la primera               

sonata para violoncello y piano en mi menor, Op. 38, de Johannes Brahms, interpretado por               

Emmanuel Feuermann y Theo van der Pas (Columbia Masterworks, Set No. 236, 1934). 

 

1) Abrimos Sonic Visualiser e importamos el archivo descargado (File > Open...):  

 
Imagen 5: Menú File de Sonic Visualiser. 
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Una vez abierto el archivo se verá una pantalla con la forma de onda del siguiente modo (si                  

por defecto apareciera como canales separados, caso de un archivo estéreo,           

seleccionamos “Channels: Mean” en la pestaña de la forma de onda en los Property Boxes               

a la derecha de la pantalla): 

 
Imagen 6: Capa ​waveform ​ de Sonic Visualiser. 

 
2) Comenzamos la reproducción con las opciones de transporte en el panel de herramientas              

o bien pulsando la barra espaciadora del teclado del ordenador. 

 
Imagen 7: Opciones de transporte. 

 
3) Cambiamos la opción “Follow Playback” a “Scroll” para que se desplace la pantalla a               

medida que se reproduce el archivo de audio. 

 
Imagen 8: Opciones de seguimiento visual del ​playback ​. 

 
4) Como ya ha sido señalado en la explicación del menú, la interfaz de usuario de Sonic                 

Visualiser está estructurada en torno a paneles (Panes) y capas (Layers). Un panel es una               
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ventana individual que presenta una herramienta de análisis determinada –por ejemplo, un            

espectrograma–; una capa es un conjunto de herramientas que se pueden superponer en             

un panel, por ejemplo, una forma de onda sobre un espectrograma. Se pueden acumular              

tantos paneles como se desee (en el caso de completar la ventana visible de la pantalla del                 

ordenador, aparecerá un ​scroll para navegar por diferentes paneles dentro de un eje             

vertical). 

 

5) Al igual que un editor de audio, Sonic Visualiser permite realizar Zoom In y Zoom Out                 

sobre la onda a través de diferentes métodos: flechas verticales del teclado (↑ para Zoom In                

y ↓ para Zoom Out), las ruedas que podemos encontrar en la parte inferior derecha de la                 

ventana u otras opciones como el ​trackpad de un ordenador portátil o la rueda del mouse.                

Para volver a una vista completa del archivo en pantalla presionamos F en el teclado. 

 

6) Las flechas horizontales ← → del teclado nos permiten a su vez navegar por el archivo                 

hacia delante y hacia atrás (empleando las flechas junto a la tecla ctrl en el PC o cmd en                   

Mac podemos dar saltos temporales mayores en el archivo). Si hacemos una selección y              

hacemos clic en “Constrain Playback to Selection” sólo escucharemos lo que está            

seleccionado.  

 

7) Sonic Visualiser cuenta con las siguientes capas (​layers​):  

● Waveform layer​: muestra una forma de onda con amplitud “peak to peak” de todo el               

archivo de audio. El eje Y se puede ajustar en función de diferentes opciones de               

visualización: 

○ Linear (por defecto): la escala es proporcional al nivel de voltaje de la salida de               

audio resultante. 

○ dB​: la escala es proporcional al logaritmo del voltaje absoluto. 

○ Meter​: se usa una escala intermedia que puede ser “no lineal”, con la intención de               

hacer que los picos sean más aparentes que en la escala dB, pero las secciones               

silenciosas son más fáciles de ver que en la escala lineal. 

 

● Spectrogram layer​: ​la capa de espectrograma muestra datos de audio en el dominio             

de la frecuencia, representando el “sonido en tres dimensiones” (Cook 2009a). El eje Y              

corresponde a la frecuencia y la energía de cada frecuencia dentro de un eje X               

temporal. La mayor o menor presencia de frecuencias viene determinada por el brillo o              

el color de los píxeles correspondientes a esa frecuencia. Hay tres tipos de capa de               

10 



espectrograma disponibles en el menú de Sonic Visualiser: ​Plain ​, ​Melodic Range y            

Peak Frequency​. Estos difieren sólo en las propiedades iniciales con las que está             

configurada la capa. Se puede convertir cualquier tipo de espectrograma en otro tipo             

ajustando sus propiedades después de que se haya creado. 

 
Imagen 9: Representación de un espectrograma en Sonic Visualiser. 

 
● Spectrum​: ​la capa de espectro muestra un análisis frecuencial del audio en un punto              

determinado. Es similar a un corte vertical a través del espectrograma. A diferencia de              

casi todos los otros tipos de capas, el eje X de una capa de espectro no mide el tiempo.                   

El eje X de la capa espectro corresponde en este caso a la frecuencia, con las                

frecuencias más bajas a la izquierda y las más altas a la derecha. El espectro, en lugar                 

de desplazarse, se ajusta de forma sincrónica al movimiento del tiempo durante la             

reproducción y la navegación.  
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Imagen 10: Representación gráfica del espectro en un momento concreto del archivo de audio. 

 
● Time Ruler layer​: muestra una serie de divisiones temporales. 

 
Imagen 11: Representación gráfica de la capa Time Ruler. 
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7. Parámetros de análisis en un espectrograma 

McAdams, Depalle y Clarke (2004) identifican -basándose en las técnicas de escalamiento            

multidimensional propuestas por Plomp (1970), Grey (1977) y McAdams (1995)- un conjunto            

de dimensiones perceptuales que constituyen el timbre y que permiten su deconstrucción en             

elementos más precisos, proponiendo los siguientes conceptos: 

● Centroide espectral (Spectral centroid)​: visible en una representación espectral         

por el peso relativo de las partes altas y bajas del espectro frecuencial. Un centroide               

espectral más alto nos dará un sonido “brillante”. 

● Cualidad de ataque (Attack quality)​: visible en una representación temporal,          

incluye el tiempo de ataque y la presencia de parciales transitorios (​transients​) de             

ataque en el comienzo de un sonido. 

● Uniformidad de la envolvente espectral (Smoothness of the spectral envelope)​:          

visible en una representación espectral. Un clarinete, por ejemplo, que se caracteriza            

por tener unos armónicos impares fuertes y unos armónicos pares débiles, nos dará             

una envolvente espectral desigual. 

● Grado de evolución de la envolvente espectral a lo largo de una nota (Degree              
of evolution of the spectral envelope over the course of a note)​: visible en una               

representación tiempo-frecuencia. Algunos instrumentos, como el clarinete, tienen        

una envolvente bastante constante, mientras que otros tienen una envolvente que se            

abre hacia las frecuencias altas cuando la intensidad de la nota aumenta, como en el               

caso de los instrumentos de viento metal. 

● Aspereza (Roughness)​: visible en una representación temporal. Los sonidos         

suaves tienen muy poco golpeo y fluctuación, mientras que los sonidos ásperos son             

más chirriantes e inherentemente disonantes. 

● Ruido/inarmonicidad (Noisiness/inharmonicity)​: visible en la representación      

espectral. Los sonidos armónicos casi puros, como los instrumentos de viento, se            

pueden distinguir de los sonidos inarmónicos como las campanas tubulares o de            

sonidos claramente ruidosos como los de los platillos y las cajas. 

 

En la práctica, la interpretación de los espectrogramas es relativamente sencilla: 

● El eje X (horizontal) corresponde al desarrollo temporal de la pista de audio, de              

izquierda a derecha. 
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● El eje Y (vertical) indica las frecuencias de los parciales o armónicos de los sonidos.               

Los armónicos graves del espectro están representados en la parte baja del eje Y,              

mientras que los armónicos superiores ocupan posiciones más altas. 

● Los colores -o las tonalidades si se emplea un espectrograma en blanco y negro-              

indican diversos grados de prominencia de los armónicos. En un espectrograma           

visualizado en verde (Colour: Green en la caja de propiedades de la derecha), las              

tonalidades rojas o naranjas indican una mayor prominencia del armónico en           

cuestión, en comparación con aquellos representados en amarillo o verde.  

● El brillo de las tonalidades se corresponde con la intensidad o volumen, aunque la              

correlación no es totalmente directa. 

● Por implicación, las tonalidades rojas o anaranjadas y bien definidas al comienzo de             

las notas indican una acentuación fuerte o marcada, mientras que la falta de colores              

brillantes denota una articulación más suave. 

Además del timbre, los espectrogramas son especialmente útiles para analizar la           

articulación, incluyendo efectos de vibrato, ​glissandos y portamentos, y la afinación. Al situar             

el cursor sobre una determinada frecuencia, aparece en la pantalla un cuadro con los datos               

referentes a su frecuencia (Bin Frequency) y su clasificación dentro del sistema temperado             

(Bin Pitch). 

En general, la visualización más cómoda es la que se obtiene seleccionando los siguientes              

parámetros en la caja de propiedades de la derecha de la capa: 

 
Imagen 12: Caja de propiedades del espectrograma.  

 

Colour: Green 

Scale: dBV^2 None 

Window: 1024 50% 1x 

Bins: All Bins Linear  
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8. La capa de instantes y la determinación de los pulsos 

 
La capa de instantes de tiempo (Time Instants) muestra una secuencia editable de puntos              

en el tiempo (Instants) mostrados como una serie de barras verticales que ocupan toda la               

altura de la capa. Cada instante puede tener una etiqueta, que se mostrará cerca de la parte                 

superior del instante. 

Los instantes se pueden agregar haciendo clic con la herramienta de dibujo y editar               

arrastrando con la herramienta de edición . También se puede hacer doble clic en un               

instante con la herramienta de edición o navegación para abrir un cuadro de               

diálogo de edición en el que se puede cambiar el texto de la etiqueta y ajustar su                 

sincronización. El parámetro Plot Type nos permite tener diferentes opciones de           

visualización. 

Para crear divisiones y subdivisiones de compás en el archivo de audio debemos realizar              

las siguientes acciones:  

 

1. Abrimos Edit > Number New Instants, y comprobamos que “Simple counter” está            

seleccionado. 

2. Ahora reproducimos la música y a medida que suena vamos pulsando la tecla punto y               

coma “;” en cada comienzo de compás o pulsamos dentro de él. En algunos              

ordenadores esta función se activa con el tabulador. 

3. Al reproducir la música escucharemos un clic al comienzo de cada una de las divisiones               

temporales que hemos creado (se pueden silenciar los clics en el botón de “Play” en la                

parte inferior derecha de la capa “Time Instants”). 

4. Comparamos el resultado con lo que aparece en el fichero Brahms Op. 38iii - F&vdP -                

crotchets.sv, disponible para descarga ​aquí (Importante: para poder visualizarlo, hay          

que enlazarlo de nuevo con el audio ya descargado anteriormente). 

5. Dado que la inserción precisa de estas barras (o “Tappings”) es compleja, normalmente             

hay que ajustarlas posteriormente. Para ello, es recomendable bajar la velocidad de            

reproducción del audio (Playback > Slow Down o girar el mando circular en la parte               

inferior derecha de la pantalla) y alinear las barras con los comienzos de nota que se                
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observan en el espectrograma. Para ajustar, iremos al modo edición , colocaremos            

el cursor en la línea que queramos mover y pincharemos y arrastraremos.  

6. Para seguir operando con estas subdivisiones en etapas posteriores del análisis,           

conviene guardar los datos numéricos en forma de archivo de texto .txt. Para ello,              

debemos asegurarnos de que la capa de Time Instants está seleccionada. Vamos a File              

> Export Annotation Layer. 

 

Si se dispone del primer pulso (anacrusa), se puede introducir a ojo con el icono del lápiz y                  

luego comprobarlo escuchando y modificando su lugar. Los problemas más habituales           

surgen en música polifónica cuando los comienzos de dos notas teóricamente alineadas            

temporalmente no ocurren a la vez. Para establecer cuál es el pulso “guía” deberás decidir               

cuál es tu criterio.  

Seguidamente hemos de numerar las barras de instantes. Podemos hacerlo de           

manera correlativa (Edit > Number New Instants with > Simple Counter), o por compás,              

indicando los pulsos dentro de ellos. En el segundo caso, nos aseguraremos de que la capa                

de “Time Instants” (pulsos) está activada. Seleccionamos del menú Edit > Number New             

Instants with, y “Cyclical two-level counter (bar/beat)”.  

 

● El tamaño del ciclo (Cycle syze) se corresponde con el número de pulsos dentro de               

cada compás. Por ejemplo, si se trata de un 2/4, el tamaño del ciclo será de 2; si es                   

un 3/4, será de 3; si es un 4/4, de 4, y así sucesivamente.  

● Si el compás empieza en anacrusa, indicamos en Edit > Set Numbering Counters –              

Coarse counter (compases) = 0. De nuevo, el Fine counter se corresponde con el              

número de pulsos dentro de cada compás. En un compás de 3/4, éste será de 3.  

● Para numerar toda la pista, seleccionamos Edit > Select All. Si, por el contrario,              

queremos numerar sólo una sección, tendremos que seleccionarla con el ratón,           

pinchando dentro del primer pulso que queremos numerar y arrastrando hasta el            

final de nuestra selección. Una vez hecho esto en ambos casos, iremos a Edit>              

Renumber Selected Instants.  

● Para poner los contadores a cero, hay que ir a Edit > Reset Numbering Counters. 

● Compara tus resultados con los del fichero Brahms Op. 38iii - F&vdP - crotchets.sv.              

En él, el compás de 4/4 está subdividido en 4 negras.  
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Imagen 13: Capa Time Instants en Sonic Visualiser. 

  
 

9. Análisis de la agógica 
 
Para realizar un estudio de la variación del ​tempo y de la duración de los pulsos en una                  

determinada pista de audio, tenemos que partir de la subdivisión precisa en pulsos (y              

compases), tal y como se acaba de explicar.  

El siguiente paso será obtener datos empíricos de la variación de tempo de un pulso a                

otro (en pulsos por minuto, bpm) o de la duración de dichos pulsos (en segundos). Para                

ello: 

○ Comprobamos que la capa de “Time Instants” está seleccionada y “encima”           

de  las demás. 

○ En el menú Edit, seleccionamos todo (Select All), y copiamos (Copy o            

Ctrl+C). 

○ Creamos una nueva capa (Layer) de valores temporales: menú Layer > Add            

New Time Values Layer, y hacemos “Paste” (o Ctrl+V). 

○ Se abre un cuadro de diálogo en el que podemos elegir cómo queremos que              

se contabilicen los datos: 
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■ En el caso de querer datos de variación de tempo, en bpm y con              

valores altos indicando mayor velocidad, elegiremos “Tempo (bpm)        

based on duration since previous item” (Tempo desde el valor          

anterior) – se refleja el tempo hasta el pulso en cuestión. La escala             

muestra valores de metrónomo. Podría medirse a partir del pulso          

seleccionado hasta el siguiente (“Tempo (bpm) based on duration to          

following item”), pero es menos frecuente en la literatura y crea           

algunos problemas en etapas de análisis posteriores. 

 
          Imagen 14: Time values layer con ajuste de tempo desde el valor anterior. 

 
■ En caso de querer datos de duración de pulsos, en segundos, con            

valores altos indicando duraciones más largas y, por tanto, un tempo           

más lento, seleccionamos “Duration to the following item”. Lo dicho          

más arriba es aplicable para la opción inversa aquí. 
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Imagen 15: Time values layer con ajuste de tempo desde el valor siguiente. 

 
 

○ Este tipo de gráficos pueden visualizarse como: 

■ Puntos aislados 

■ Stems 

■ Puntos conectados 

■ Líneas 

■ Curvas 

■ Segmentos 

■ Curvas discretas 

 

Seleccionamos el que prefiramos en el cuadro de la derecha de la capa correspondiente.              

Para obtener los datos numéricos de cada una de las mediciones, tendremos que exportar              

la capa a un archivo de texto .txt en File > Export Annotation Layer (Ctrl+Y). Hay que                 

asegurarse de que la capa deseada está seleccionada y de que nuestro archivo de texto se                

guarda con un nombre que se pueda reconocer bien a lo largo de todo el proceso de                 

análisis. 
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10. Análisis de las dinámicas 

Para generar un gráfico de dinámicas dentro del propio programa, abriremos “Analysis by             

Plugin Name > Power Curve > Smoothed Power ” en el menú “Transform”. Aceptamos los              1

valores por defecto y nos aparecerá una curva (para mayor claridad se puede seleccionar la               

opción View > Show No Overlays). 

 
Imagen 16: Gráfica Smoothed Power en Sonic Visualiser. 

 
 
Para exportar los datos numéricos, haremos como en el caso de la agógica: File > Export                

Annotation Layer.  

Sonic Visualiser analiza la dinámica en forma de variación continua, por lo que             

proporciona un número de mediciones muy elevado que no se corresponde con las barras              

de instantes que hemos creado en pasos previos. Para obtener una correlación entre los              

instantes y las muestras de intensidad dinámica, hemos de recurrir a la aplicación en línea               

1 Para poder utilizar esta función, hay que tener instalado el ​plugin correspondiente. Véase más               
abajo. 
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Dynamatic desarrollada por el Mazurka Project, disponible en        

http://www.mazurka.org.uk/software/online/dynamatic/​. En ella tendremos que importar los       

archivos .txt correspondientes a los instantes temporales (en “Tap Times”) y a los valores              

de la dinámica (en “Loudness Samples”).  

 
Imagen 17: Vista principal del ​software on line ​ Dynamatic del Mazurka Project. 

 
 
Dejaremos los valores por defecto y, una vez enviados (Submit data) y procesados los              

datos, aparecerá una ventana con los resultados del proceso de ensamblaje: 
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Imagen 18: Resultados del proceso de ensamblaje en Dynamatic. 

 
 
Deberemos seleccionar todos los datos de la ventana y copiarlos en un nuevo archivo de 

texto .txt, que guardaremos con su nombre correspondiente. Todos los archivos .txt pueden 

ser importados en Excel para obtener gráficos de ordenadas y abscisas. 

11. Plugins 

A continuación se muestran algunos de los principales ​plugins ​disponibles para Sonic            

Visualiser. Se puede consultar el listado completo en en el siguiente ​enlace​. 

11.1. Mazurka Plugins 

● Attack 

Identifica ataques de notas en la información de audio proporcionada. MzAttack genera dos             

datos resultantes: 

1) Attack Detection Function (Función de detección de ataque): Se trata de una función             

cuyos valores oscilan entre 0 y 1. Un valor de 0 indica que es muy poco probable                 

que ese momento del audio corresponda a un ataque. Valores superiores a 0,2             

indican que es muy probable un ataque en ese momento del audio. 
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2) Detected Attacks (Ataques detectados): Muestra la posición estimada de los ataques           

en el audio. 

 

En la siguiente figura se muestra la función de detección en negro y los ataques detectados                

en naranja, superpuestos a la señal de audio en morado.  

 

 
Imagen 19: Resultado de la función MzAttack ( ​http://sv.mazurka.org.uk/MzAttack/​) 

  

El ​plugin todavía está en proceso de mejora. Todavía se dan frecuentes falsos negativos              

(ataques reales no detectados), pero no son frecuentes los falsos positivos.  

  

● PowerCurve 

 

Mide la potencia a lo largo del tiempo de la señal de audio. Entre los parámetros de entrada                  

que podemos modificar se encuentran los siguientes: 

● Tamaño de la ventana (Window Size): Duración en milisegundos de las ventanas de             

la señal que se analizarán. La potencia de la señal se irá calculando por segmentos               

o ventanas de esta longitud.  

● Tamaño de la ventana por intervalos o saltos (Window Hop Size): Determinará el             

grado de solapamiento de las ventanas de análisis. (Además, podemos modificar           

varios parámetros del filtro que se aplicará para obtener las curvas “alisadas” de             

potencia, en el caso de seleccionar esta opción). 
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MzPowerCurve permite obtener varios resultados: 

 

1) Raw Power (Potencia Bruta): Potencia media de cada bloque (ventana) de la señal             

de audio. 

2) Smoothed Power (Potencia Alisada): Curva alisada que se obtiene filtrando la señal            

anterior (Raw Power). Esta señal puede resultar más apropiada para extraer           

conclusiones, ya que se suavizan los saltos abruptos debidos a ruido y batidos que              

pueden tener lugar en la señal “Raw Power”.  

3) Smoothed Power Slope (Pendiente de la Potencia Alisada): Mide la pendiente de la             

curva anterior. Un pico en los valores de pendiente se corresponde con un             

incremento repentino de intensidad, lo cual puede significar un ataque.  

4) Scaled Power Slope (Pendiente Escalada de la Potencia): Se trata de una curva             

similar a la anterior, pero se eliminan posibles picos en los fragmentos de audio de               

baja amplitud.  

 

En la siguiente imagen se muestran ejemplos de las tres primeras:  

 
Imagen 20: Gráficas resultantes de “potencia bruta” (Raw Power, en negro), “potencia alisada” (Smoothed 

Power, en naranja) y “pendiente de la potencia alisada” (Smoothed Power Slope, en rosa). 
(​http://sv.mazurka.org.uk/MzPowerCurve/ ​) 

 

● SpectralFlux 

 

Realiza una estimación del comienzo de cada sonido teniendo en cuenta los cambios en las               

magnitudes espectrales. Mide los cambios de energía entre distintas bandas de frecuencia            

en una serie de espectros derivados de la señal de audio.  

 

La siguiente figura muestra un ejemplo de la aplicación de MxSpectralFlux en una señal de               

audio. La señal de audio aparece en naranja. En la parte inferior de la figura se muestra un                  
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espectrograma de diferencias (resultado de la comparación entre espectros de la señal en             

instantes sucesivos de esta). A partir de este espectrograma de diferencias o cambios se              

obtiene la gráfica en color verde que aparece justo debajo de la señal de audio. Los picos                 

en esta gráfica de flujo espectral pueden indicar los instantes de “onset” o comienzos de               

sonidos musicales.  

 
Imagen 21: Aplicación de MzSpectralFlux  

(​http://sv.mazurka.org.uk/MzSpectralFlux/​ )  

 

 

11.2. Vamp Aubio Plugins 

● Aubio Beat Tracker 

 

Calcula el ​tempo y la posición del pulso (​beat​). No es del todo fiable ante inflexiones                

temporales (​rubato​) o ante archivos de audio en los que demasiadas capas texturales             

pueden emborronar el pulso/​beat​. Tanto la herramienta de cálculo del ​tempo como la de              

estimación del pulso permiten modificar los siguientes parámetros: 

 

● Peak Picker Threshold (Umbral de la selección de picos): Cuanto mayor sea el valor,              

menos sensible se mostrará el ​plugin ante la detección de picos de intensidad o              

posibles cambios de tempo. 

● Silence Threshold (Umbral de detección de silencio): Cuanto mayor sea el valor,            

menos sensible se mostrará el ​plugin ante la detección de momentos de silencio, lo              
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cual se traduce del mismo modo en una menor sensibilidad a la hora de detectar               

posibles picos de intensidad (​beats​/pulso) o cambios de ​tempo​. 

 

● Aubio Onset Detector 

Calcula los momentos de ataque de cada nota. Permite obtener los siguientes resultados: 

1) Onsets (Ataques): Momentos de ataque de notas representados como líneas o           

divisiones verticales de la onda de audio. 

2) Onset Detection Function (Función de detección de ataques): Momentos de ataque           

de notas representados como una gráfica. 

3) Thresholded Onset Detection Function (Función de detección de ataques sobre un           

umbral): Momentos de ataque de notas representados como una gráfica centrada,           

en el eje vertical, en 0. 

 

Al igual que ocurría con Aubio Beat Tracker, Aubio Onset Detector nos permite manipular              

los parámetros de Peak Picker Threshold y Silence Threshold con los mismos resultados,             

aparte de Minimum Inter-Onset Interval, que determina el lapso de tiempo, en milisegundos,             

por debajo del cual dos ataques consecutivos serán representados en nuestra gráfica final             

como uno solo. 

 

● Aubio Pitch Detector 

 

Calcula las alturas de cada nota. De un modo similar a Aubio Beat Tracker, no es del todo                  

fiable ante archivos de audio en los que demasiadas capas texturales pueden emborronar,             

en este caso, la línea melódica que se desee analizar. Los parámetros que nos permite               

modificar son los siguientes: 

 

❖ Minimum Fundamental Frequency (Frecuencia fundamental mínima): La menor        

frecuencia a analizar; todas las frecuencias por debajo serán ignoradas por el ​plugin​. 

❖ Maximum Fundamental Frequency (Frecuencia fundamental máxima): La mayor        

frecuencia a analizar; todas las frecuencias por encima serán igualmente ignoradas. 

❖ Fold Higher or Lower Frequencies into Range (Condensar frecuencias altas y bajas            

dentro del rango anterior): Si la casilla es seleccionada, todas aquellas frecuencias            

que queden fuera de los límites establecidos mediante los dos parámetros anteriores            
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serán transportadas a otras octavas que sí se encuentren dentro de dichos límites.             

Si la casilla no es seleccionada, el ​plugin omitirá todas las frecuencias que queden              

fuera del rango. 

❖ Silence Threshold (Umbral de detección de silencio): Cuanto mayor sea el valor,            

menos sensible se mostrará el plugin ante la detección de momentos de silencio; en              

este caso, un valor mayor se traduce en una menor sensibilidad a la hora de               

detectar posibles alturas determinadas. 

 

11.3. BBC Vamp Plugins 

● Spectral Contrast 

 
Analiza el contraste entre los picos y valles de intensidad de un espectrograma. Este plugin               

permite la obtención de tres resultados distintos: 

1) Spectral Peaks (Picos en espectrograma): Calcula los picos de cada sub-banda de            

frecuencias (el eje Y del espectrograma dividido en múltiples rangos de frecuencias). 

2) Spectral Valleys (Valles en espectrograma): Calcula los valles de cada sub-banda de            

frecuencias. 

3) Spectral Mean (Media en espectrograma): Calcula la media de los valores de cada             

sub-banda de frecuencias. 

 

Los parámetros que Spectral Contrast nos permite modificar son los siguientes: 

 

● Alpha: Cantidad de información que el ​plugin empleará en cada sub-banda de            

frecuencias para calcular los picos y valles. 

● Sub-bands: Número de sub-bandas de frecuencia o divisiones del eje Y del            

espectrograma. Cuanto mayor sea el número de sub-bandas, mayor resolución/nivel          

de detalle tendrá el resultado de nuestro análisis. 

 

● Peaks 

Visualiza los picos en intensidad de una señal. El resultado es idéntico a la representación               

predeterminada de los archivos de sonido que abrimos en Sonic Visualiser como una onda              

(si se trata de un archivo con información en estéreo, con los dos canales, izquierdo y                
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derecho, condensados en uno solo). Este ​plugin no permite la modificación de ningún             

parámetro. 

● Intensity 

 

Analiza la intensidad de una señal de audio expresada como dos resultados distintos: 

1) Intensity (Intensidad): La suma de esta magnitud en todos los anchos de banda,             

representada como una gráfica. 

2) Intensity Ratio (Ratio de intensidad): La ratio entre la intensidad de cada ancho de              

banda y la intensidad total, representada en “bins” (“compartimentos” o “secciones”)           

de colores. 

 

Este ​plugin nos permite modificar el número de sub-bandas de frecuencia con el que              

realizar los cálculos anteriores, y también el tamaño de cada “bin” si en la ventana de                

ajustes de parámetros del ​plugin hacemos clic en “Advanced”: mayores valores en “Window             

size” y “Window increment” se traducirá en “bins” de mayor tamaño y, por tanto, en un                

resultado de análisis de menor resolución. 

 

● Rhythm: Onset 

 

Al igual que Attack (Mazurka Plugins) y Aubio Onset Detector, calcula la posición de los               

ataques de las notas en una señal de audio. Los parámetros que este ​plugin nos permite                

modificar son varios: 

● Número de sub-bandas de frecuencia (Sub-bands). 

● Umbral (Threshold): Valor límite por debajo del cual el ​plugin omitirá cualquier pico             

de intensidad y, por tanto, cualquier posible ataque de notas. Un valor mayor             

producirá un menor número de resultados. 

● Dimensiones de la media móvil (Moving Average Window Length): Determina la           

suavidad de la gráfica resultante; un valor mayor producirá una gráfica más suave,             

menos angulosa. 

● Dimensiones de la selección de picos de los ataques (Onset Peak Window Length):             

Determina la cantidad de información que tomará el plugin para realizar el análisis. 

● Mínimo número de pulsos por minuto (Minimum BPM). 

● Máximo número de pulsos por minuto (Maximum BPM). 
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Glosario 

 
● Amplitud: es el grado de compresión y descompresión del aire. En Sonic Visualiser             

viene determinada por el mayor o menor desplazamiento de los ciclos positivos y             

negativos de la onda representada en la capa ​waveform ​, y está relacionada con el              

nivel sonoro que finalmente percibimos. 

● Ancho de banda: rango determinado de frecuencias dentro del espectro sonoro. 

● BPM (​Beats per Minute​): número de pulsos por unidad de tiempo. Normalmente se             

mide en negras por minuto. 

● Bucle (​loop​): fragmento de audio reproducido en bucle, sin interrupción. 

● Capa (​layer​): capa que se superpone a otra para complementar la información del             

archivo de audio que se está analizando. 

● Compresión (de datos): reducción del volumen que ocupan los datos que           

representan una información determinada. No se debe confundir con el concepto de            

compresión aplicado al rango dinámico. 

● Decibelio (dB): en el sonido se aplica normalmente una escala logarítmica que            

emplea como unidad el decibelio, y que nos posibilita trabajar con magnitudes más             

manejables que los pascales (en el caso de la presión sonora) o los vatios (en el                

caso de la potencia).  

● Envolvente (ADSR): representación gráfica de la ejecución de una nota de un            

instrumento. La envolvente describe la evolución en el tiempo de la amplitud de una              

nota en base a cuatro estadios diferenciados: ​attack ​(ataque), tiempo que tarda en             

llegar a su punto de máxima amplitud; ​decay ​(decaimiento), tiempo que tarda la nota              

en pasar del punto de máxima amplitud al punto de sostenimiento; ​sustain            

(sostenimiento), tiempo en el que la nota permanece sostenida, y ​release           

(liberación), tiempo que el sonido tarda en desvanecerse desde que la nota es             

liberada. 

● Espectrograma: representación gráfica de la distribución de las frecuencias         

fundamentales y el contenido armónico que conforma un sonido, atendiendo a las            

intensidades de las mismas y a su evolución en el eje temporal. 

● Espectro sonoro: está relacionado con el rango frecuencial de la grabación y viene             

determinado por la limitación del soporte que haya sido digitalizado. El oído humano             

es capaz de percibir frecuencias comprendidas entre 20 Hz y 20 kHz. Este espectro              

audible es diferente en cada persona y se altera con la edad. 
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● Forma de onda: las características de una onda sonora pueden representarse           

gráficamente mediante un eje vertical, que representa la amplitud, y un eje            

horizontal, que representa el tiempo. 

● Instante de tiempo (​time instant​): marca que representa un momento determinado de            

la interpretación en la grabación. Normalmente coincidirá con una división o           

subdivisión del compás o responderá a un patrón rítmico determinado. 

● Monitorización visual: seguimiento de las características de una grabación a través           

de medidores de intensidad, rango frecuencial, rango dinámico, etc. 

● Onset: Ataque, momento de aparición de un sonido. 

● Panel (​pane​): Ventana que, en lugar de superponerse como ocurre con los Layers,             

queda apilada horizontalmente sobre o bajo otros Panes para complementar la           

información del archivo de audio que se está analizando. 

● Peak: Punto de máxima intensidad de una onda, frecuencia o rango de frecuencias. 

● Plugin: pequeña aplicación que complementa al programa informático base. En el           

caso de Sonic Visualiser, los ​plugins actúan como herramientas adicionales de           

análisis musical. 

● Rango melódico: ámbito, extensión de alturas sonoras que abarca una línea           

melódica. 

● Transform: en Sonic Visualiser es la sección dentro del menú que permite aplicar las              

funcionalidades de los plugins al audio que hayamos importado. 

● Transitorio: sonido con un ataque muy rápido y de gran amplitud. 
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